HOTRODRHINOFORUMS.COM

Yamaha Rhino
 
HomeHome  PortalPortal  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  

We have recently moved our forum to vBulletin, part of moving means that you are required to reset your password. If you follow this link and enter your email address you will be emailed directions to resetting your password.

http://hotrodforums.net/forums/login.php?do=lostpw&email=$email


Who is online?
In total there are 14 users online :: 0 Registered, 0 Hidden and 14 Guests :: 2 Bots

None

Most users ever online was 207 on Tue Jun 11, 2013 11:13 pm
Latest topics
» NEW FORUM!
Fri Dec 13, 2013 12:08 pm by 123.bert0621

» What will be edited to the new 'Hot Rod Forum'
Fri Dec 13, 2013 11:01 am by WV Hot Rod Rhino

» Forgot what the new sites name is?????
Fri Dec 13, 2013 10:59 am by WV Hot Rod Rhino

» Truck picture thread.
Fri Dec 13, 2013 9:33 am by Tacoclaw

» go to new forum for tonight
Fri Dec 13, 2013 7:50 am by chuddly

» First rhino 09 450
Fri Dec 13, 2013 7:47 am by chuddly

» New guy from Texas with my first rhino
Fri Dec 13, 2013 7:44 am by chuddly

» big boring the 660
Fri Dec 13, 2013 5:02 am by rhinosport84

» Who else is in Houston
Fri Dec 13, 2013 2:49 am by Stapleton1184

Top posters
WV Hot Rod Rhino
 
madmax 1
 
REDRHINO64
 
ASPENDELLROVER
 
T.Rhino
 
123.bert0621
 
Firefighter
 
rhino727
 
CUSTOMIZEDRHINO13
 
flimmy
 
Most Viewed Topics
1st Annual Hot Rod Rhino Forums Ride Oct 4th-6th
Hello hot rod forum
NEW 2014 SxS PHOTOS....................
ALBA 734 Big Bore for 2011 Rhino 700
Picture Gallery
New Yamaha SXS coming June 11 2013??.
Sand Reeper
Rhino 700 Electrical Problem - Solved!
Hunterworks misleading rhino owners again
NEW FORUM!
Most active topics
1st Annual Hot Rod Rhino Forums Ride Oct 4th-6th
ALBA 734 Big Bore for 2011 Rhino 700
Picture Gallery
Truck picture thread.
What do you do for a living ?
New Yamaha SXS coming June 11 2013??.
EZ Steer Power Steering install
BUMPERS rhino.... evergoing build thread
Show Your House/Compound
Looking for a better holeshot
Top posting users this week
Search
 
 

Display results as :
 
Rechercher Advanced Search

Share | 
 

 Water pump failure?

View previous topic View next topic Go down 
AuthorMessage
honda450sfm

avatar

Posts : 194
Join date : 2013-03-21
Location : Calgary CAN

PostSubject: Water pump failure?   Fri May 31, 2013 12:15 am

There's coolant leaking from the breather tube on my 06-660. The pump is still working fine, it's just dripping out the tube.
Do I need a whole new water pump or just a seal kit?

_________________
06-660
JBS sheave 14g
Purple Spring
Back to top Go down
View user profile
rhino727

avatar

Posts : 1317
Join date : 2013-03-25
Age : 53
Location : musella,Ga.

PostSubject: Re: Water pump failure?   Fri May 31, 2013 12:23 am

I replaced mine , but kept the old one to see about rebuilding to have as back up.

_________________
2007 Special Edition 660, Hotrods crank 4mm stroker , wiseco 2mm over 10/1 piston, new head ported +2 valves,  mudbuster cam, billet middle gear support, JBS sheave 14g with purple spring an friction washers , new wet clutch + 6g lead, Gibson header&muffler,4000lbs winch,26 in mud-lites  ,3in lift, snorkeled, dyna jet kit, K&N air filter with pro-flow adapter, floorboard guards, radiator guards, fender flares
Back to top Go down
View user profile
 
Water pump failure?
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» water pump SWP/LWP
» Non A/C Small Block Mopar Crank and Water pump pulley and Alt. Bracket
» Advise on oil/water pump rebuild
» how to tell short from long water pump for Chevy
» replacing seals for water pump

Permissions in this forum:You cannot reply to topics in this forum
HOTRODRHINOFORUMS.COM :: Technical :: Engine-
Jump to: