HOTRODRHINOFORUMS.COM

Yamaha Rhino
 
HomeHome  PortalPortal  Events  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  

Welcome to the forum!! also check us out at hotrodforums.net


Who is online?
In total there are 15 users online :: 0 Registered, 0 Hidden and 15 Guests :: 1 Bot

None

Most users ever online was 207 on Tue Jun 11, 2013 11:13 pm
Latest topics
» rhino 660 hid visionx headlights for sale
Thu Dec 14, 2017 4:54 pm by WV Hot Rod Rhino

» New JBS Extreme sheave milling
Thu Dec 14, 2017 1:28 am by WV Hot Rod Rhino

» forum back open for posting
Thu Dec 14, 2017 1:24 am by WV Hot Rod Rhino

» NEW FORUM!
Thu Dec 14, 2017 12:35 am by WV Hot Rod Rhino

» What will be edited to the new 'Hot Rod Forum'
Fri Dec 13, 2013 11:01 am by WV Hot Rod Rhino

» Forgot what the new sites name is?????
Fri Dec 13, 2013 10:59 am by WV Hot Rod Rhino

» Truck picture thread.
Fri Dec 13, 2013 9:33 am by Tacoclaw

» go to new forum for tonight
Fri Dec 13, 2013 7:50 am by chuddly

» First rhino 09 450
Fri Dec 13, 2013 7:47 am by chuddly

Top posters
WV Hot Rod Rhino
 
madmax 1
 
REDRHINO64
 
ASPENDELLROVER
 
T.Rhino
 
123.bert0621
 
Firefighter
 
rhino727
 
CUSTOMIZEDRHINO13
 
flimmy
 
Most Viewed Topics
1st Annual Hot Rod Rhino Forums Ride Oct 4th-6th
Hello hot rod forum
NEW 2014 SxS PHOTOS....................
ALBA 734 Big Bore for 2011 Rhino 700
Picture Gallery
NEW FORUM!
What do you do for a living ?
BUMPERS rhino.... evergoing build thread
My full review of the JBS sheave kit
New Yamaha SXS coming June 11 2013??.
Most active topics
1st Annual Hot Rod Rhino Forums Ride Oct 4th-6th
ALBA 734 Big Bore for 2011 Rhino 700
Picture Gallery
Truck picture thread.
What do you do for a living ?
New Yamaha SXS coming June 11 2013??.
EZ Steer Power Steering install
BUMPERS rhino.... evergoing build thread
Show Your House/Compound
Looking for a better holeshot
Top posting users this week
Search
 
 

Display results as :
 
Rechercher Advanced Search

Share | 
 

 JBS Sheave PROBLEM

Go down 
Go to page : 1, 2  Next
AuthorMessage
surfdoggins



Posts : 7
Join date : 2013-09-07

PostSubject: JBS Sheave PROBLEM   Sat Sep 21, 2013 7:00 pm

Installed my JBS hotrod sheave today but doesn't seem to be working. At about 32 to 33 MPH, my Rhino starts cutting out and at about 36 MPH its completely dead like its starving for fuel. Tried putting it in low and at about 26 to 27 MPH it does the same thing. Thought maybe I installed something wrong so I took everything apart and re-installed everything again. Just took it out again and it does the same thing. Seems to run okay under 32 MPH but I can't seem to notice any difference in performance. But when it hits about 32+ MPH it just cuts out and won't go any faster.

I have a 2011 700 with 18g weights and 26" tires. Any suggestions? Tried calling James but his mailbox is full.
Back to top Go down
View user profile
pageandbeth

avatar

Posts : 20
Join date : 2013-04-11
Age : 35
Location : Robeline, La

PostSubject: Re: JBS Sheave PROBLEM   Sat Sep 21, 2013 7:05 pm

Take some pics of the sheave with weights and cam plates installed and removed.
Back to top Go down
View user profile
flimmy

avatar

Posts : 988
Join date : 2013-03-10
Age : 50
Location : Mt. Pleasant , Pa

PostSubject: Re: JBS Sheave PROBLEM   Sat Sep 21, 2013 7:20 pm

Do you have the stock cdi box ? They have a rev limiter that may be your problem. I know  the 660's have them and that's what can happen

_________________
06 JBS built 686 , Benachmark ported head , Falicon rod Trail Bright led's , JBS sheave , Alba pipe and fuel pump , custom cage , HID head lights , 26" GBC Dirt Tamers on SS212 wheels , Superwinch Terra 45 w/ Synthetic Rope , Dynatek CDI

Owner of


www.trailbrightled.com

Moto Alliance dealer

Pro Armor dealer

Rocky Mountain ATV dealer
Back to top Go down
View user profile http://www.trailbrightled.com
REDRHINO64

avatar

Posts : 1649
Join date : 2013-03-10
Age : 53
Location : Asheboro N.C./Mountain Top West By God Virginia

PostSubject: Re: JBS Sheave PROBLEM   Sat Sep 21, 2013 7:50 pm

weights in wrong...these things run 42 stock.

_________________
2007 rhino,720cc,Falicon super crank,JE 10:75:1 piston,stage 1 raptor cam,Bored Fcr 43mm carb,unifilter,muzzys,Jbs sheave and 14 gram Ods,orange spring,anti friction washers,slugged clutch,Jbs roof,Jbs radiator shields,jbs sticker=10hp,full windshield,siesmik doors,Se shocks,Summit heater,5000lb winch,Power steering,tach and guages,2 way radio,mp3 to 400 watt amp,4 polk speakers,4 Hid lights,alternator,and the list goes on!!
Back to top Go down
View user profile
WV Hot Rod Rhino
Admin
avatar

Posts : 2682
Join date : 2013-03-10
Age : 51
Location : Mt. Hope, WV

PostSubject: Re: JBS Sheave PROBLEM   Sat Sep 21, 2013 8:12 pm

call me now..

_________________
2009 Yamaha Rhino 787
Hot Rod Rhino Sheave, Falicon 734 Cylinder, +6 Falicon Stroker Crank, Benchmark +1 Ported Head & T/B, JBS Deshrouded Valves, 10:1 CP Piston, 3D MSD, Dynatek Coil, Dual Muzzy's

If you need any help or have any questions give me a call 304-673-2602 or 304-877-3419
James Davis, 131 Davis Ct., Mt. Hope, WV 25880
jamesbodyshop@hotmail.com

https://www.youtube.com/user/WVHotRodRhino
http://www.facebook.com/jamesnnikki.davis
Back to top Go down
View user profile
scottwv



Posts : 601
Join date : 2013-03-10
Age : 46
Location : Charleston , WV

PostSubject: Re: JBS Sheave PROBLEM   Sat Sep 21, 2013 11:52 pm

Need to keep technical questions here !
Back to top Go down
View user profile
ASPENDELLROVER

avatar

Posts : 1638
Join date : 2013-03-10
Age : 45
Location : CA

PostSubject: Re: JBS Sheave PROBLEM   Sun Sep 22, 2013 2:20 am

yep RF dont work for shit

_________________
Just a Family Comfort Wagon, w/+6 LT and JBS sheave...all ya need
Back to top Go down
View user profile
WV Hot Rod Rhino
Admin
avatar

Posts : 2682
Join date : 2013-03-10
Age : 51
Location : Mt. Hope, WV

PostSubject: Re: JBS Sheave PROBLEM   Sun Sep 22, 2013 11:52 am

i got this forum for my customers and they still ask them over there

_________________
2009 Yamaha Rhino 787
Hot Rod Rhino Sheave, Falicon 734 Cylinder, +6 Falicon Stroker Crank, Benchmark +1 Ported Head & T/B, JBS Deshrouded Valves, 10:1 CP Piston, 3D MSD, Dynatek Coil, Dual Muzzy's

If you need any help or have any questions give me a call 304-673-2602 or 304-877-3419
James Davis, 131 Davis Ct., Mt. Hope, WV 25880
jamesbodyshop@hotmail.com

https://www.youtube.com/user/WVHotRodRhino
http://www.facebook.com/jamesnnikki.davis
Back to top Go down
View user profile
scottwv



Posts : 601
Join date : 2013-03-10
Age : 46
Location : Charleston , WV

PostSubject: Re: JBS Sheave PROBLEM   Sun Sep 22, 2013 11:55 am

Yeah, they start smothering out , whenever you don't answer !   Rolling Eyes
Back to top Go down
View user profile
banchee6

avatar

Posts : 566
Join date : 2013-03-10
Age : 44
Location : belle rose, la

PostSubject: Re: JBS Sheave PROBLEM   Sun Sep 22, 2013 12:00 pm

sounds like my issue, all weights were flipped....

_________________
2009 Rhino SE Red  SOLD SOLD

2014 RZR 800S LE, 29.5 Terminators on 14" MSA Kore black wheels, 2"-3" Super Atv Lift, Ice Blue LEDs
30" LED Light Bar, Alpine 5 Channel Amp
6. 6" Kicker 2Way's with 1. 10" Kicker Sub
Custom Painted/Powder Coated Roof, Laser Etched Switched On Dash, Dual Batteries, Extra Fuse Block
 
Look up CoonAss Slingers on Facebook,, We always riding some wheres......
Back to top Go down
View user profile
pageandbeth

avatar

Posts : 20
Join date : 2013-04-11
Age : 35
Location : Robeline, La

PostSubject: Re: JBS Sheave PROBLEM   Sun Sep 22, 2013 1:03 pm

Yea i ran into that the other day. There was a few weights that was flipped and slider bushings were upside down.
Back to top Go down
View user profile
surfdoggins



Posts : 7
Join date : 2013-09-07

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 2:18 am

I know I got the bushings on correct. But not sure about the weights. I put the side with the couple grooves on the bottom facing the center. Is this correct?
Back to top Go down
View user profile
ASPENDELLROVER

avatar

Posts : 1638
Join date : 2013-03-10
Age : 45
Location : CA

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 2:26 am

pictures would help

_________________
Just a Family Comfort Wagon, w/+6 LT and JBS sheave...all ya need
Back to top Go down
View user profile
Yotehunter66
Moderator
avatar

Posts : 674
Join date : 2013-03-10
Age : 52
Location : Clayton, Mi

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 6:42 am

Pull the cover and rev it up and see if your belt is riding to the top of your primary and secondary sheaves.

_________________
Kawasaki Prairie 400
Suzuki Ozark 250
Suzuki 230



Last edited by Yotehunter66 on Mon Sep 23, 2013 6:43 am; edited 1 time in total (Reason for editing : Add to it.)
Back to top Go down
View user profile
scottwv



Posts : 601
Join date : 2013-03-10
Age : 46
Location : Charleston , WV

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 8:01 am

surfdoggins wrote:
I know I got the bushings on correct. But not sure about the weights. I put the side with the couple grooves on the bottom facing the center. Is this correct?
If you have the sheave on the bench , the grooves you are referring to , should be on top ; and , against the center of the sheave.  There should've been an illustration in the package the od's were in.
Back to top Go down
View user profile
surfdoggins



Posts : 7
Join date : 2013-09-07

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 8:28 am

Anybody have a picture of how the weights should be installed? I don't recall seeing anything in the packaging.
Back to top Go down
View user profile
Crusty

avatar

Posts : 431
Join date : 2013-08-10
Age : 48
Location : Woods Cross Utah

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 9:57 am

https://www.youtube.com/watch?v=61ODAYyWyyA
This will show you exactly how they go.

_________________
cheers It's not that wide but it sure is short!
Back to top Go down
View user profile
WV Hot Rod Rhino
Admin
avatar

Posts : 2682
Join date : 2013-03-10
Age : 51
Location : Mt. Hope, WV

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 10:26 am

thanks..

_________________
2009 Yamaha Rhino 787
Hot Rod Rhino Sheave, Falicon 734 Cylinder, +6 Falicon Stroker Crank, Benchmark +1 Ported Head & T/B, JBS Deshrouded Valves, 10:1 CP Piston, 3D MSD, Dynatek Coil, Dual Muzzy's

If you need any help or have any questions give me a call 304-673-2602 or 304-877-3419
James Davis, 131 Davis Ct., Mt. Hope, WV 25880
jamesbodyshop@hotmail.com

https://www.youtube.com/user/WVHotRodRhino
http://www.facebook.com/jamesnnikki.davis
Back to top Go down
View user profile
Crusty

avatar

Posts : 431
Join date : 2013-08-10
Age : 48
Location : Woods Cross Utah

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 10:44 am

UBETCHA!

_________________
cheers It's not that wide but it sure is short!
Back to top Go down
View user profile
Bayou Tiger

avatar

Posts : 341
Join date : 2013-03-14
Age : 53
Location : Central Florida

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 2:03 pm

A liitle research on video's works wonders instead of going in blind, just saying...

_________________
2012 700SE
JBS HotRod Sheave with purple spring/anti-friction washers & 16g weights, greased~~Dynatek CDI~~Rigid HID Hi/Lo Headlights~~26" Maxxis BigHorn Tires on 14" MSA M20 Black Kore wheels~~CFM 2" Lift~~Pro Aluminum front and rear skid plates~~4500# Venom winch/synthetic cable~~3 gauge panel w/ switches~~RZR seats~~2 Custom made Dune flag holders
Back to top Go down
View user profile
Crusty

avatar

Posts : 431
Join date : 2013-08-10
Age : 48
Location : Woods Cross Utah

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 2:22 pm

I actually watched James video while I did my install and would pause & rewind as needed and everything went into place perfectly, very informative videos.

_________________
cheers It's not that wide but it sure is short!
Back to top Go down
View user profile
jnalley_01



Posts : 48
Join date : 2013-09-10
Location : malaga ohio

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 2:37 pm

X2 i did that same thing install went smooth
Back to top Go down
View user profile
wagon1

avatar

Posts : 38
Join date : 2013-07-08
Age : 45
Location : King George, Va

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 4:27 pm

I followed the video when I did mine and it was right on the money.

_________________
2007 Rhino 660 JBS Sheave, Orange Spring, Hunterworks Tri-Fire CDI, Air box mod, Muzzy Exhaust, Dyno Jet Carb kit, 700 Belt, Viper 5000 winch, LED Light bar, 14" ITP Rims w Pro Comp tires, Siezmik full enclosure and center console.
Back to top Go down
View user profile http://www.sawdy.com
madmax 1

avatar

Posts : 1743
Join date : 2013-03-10
Age : 52
Location : frostburg md

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 7:39 pm

jnalley_01 wrote:
X2 i did that same thing install went smooth
x3 nothing helps more than some good videos

_________________
07 camo 660, hmf pipe, k&n filter, dynatec cdi, jet kit, montana jack f&r winch mount w/warn xt40, 27" mudlites, hids, leds, 2" lift cab w/ heat, j strong half doors for summer, aux red top optima for accessories, roof rack , 5 bad ass jrt's on board, itp ss212's, jbs sheeve,14gr wts., orange spring,40" led litebar, autometer guages, equus tach, innovate afm
Jensen ms30, jbl 6.5's, elka stage 1 shocks, kenwood 2way radio
Back to top Go down
View user profile
ASPENDELLROVER

avatar

Posts : 1638
Join date : 2013-03-10
Age : 45
Location : CA

PostSubject: Re: JBS Sheave PROBLEM   Mon Sep 23, 2013 11:19 pm

and some herbal insight...lol

_________________
Just a Family Comfort Wagon, w/+6 LT and JBS sheave...all ya need
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: JBS Sheave PROBLEM   

Back to top Go down
 
JBS Sheave PROBLEM
Back to top 
Page 1 of 2Go to page : 1, 2  Next

Permissions in this forum:You cannot reply to topics in this forum
HOTRODRHINOFORUMS.COM :: Technical :: Clutching-
Jump to: